Debian 6.0 armv5

The sniffer version >= 7 requires GCC compiler 4.7 and newer this on Debian without compiling GCC 4.7 is not possible to compile the latest sniffer. We recommend to use Debian 7.

Here you can download various images for dreamplug:

http://www.downloadsnewit.co.uk/SD-images/Dreamplug/


apt-get install build-essential subversion libvorbis-dev libpcap-dev apache2 php5-mysql php5-gd mysql-server unixodbc-dev libapache2-mod-php5 php5-gd php5-mysql php5 php5-cli apache2 libapache2-mod-php5 tshark mtr mysql-server php5-mcrypt librsvg2-bin libmysqlclient-dev
cd /usr/src/
http://svn.code.sf.net/p/voipmonitor/code/tags/release_6.5.4/ voipmonitor-6.5.4
cd voipmonitor-6.5.4
cp Makefile.in Makefile
make armv5shared
make install
cp config/voipmonitor.conf /etc/
cp config/init.d/voipmonitor /etc/init.d/
update-rc.d voipmonitor defaults
/etc/init.d/voipmonitor start
mysqladmin create voipmonitor
cd /var/www
wget "http://www.voipmonitor.org/download-gui?version=latest&major=5&festry" -O w.tar.gz
tar xzf w.tar.gz 
mv voipmonitor-gui*/* ./ 
rm index.html 
mkdir /var/spool/voipmonitor/ 
chown www-data /var/spool/voipmonitor/ 
touch "/var/www/bin/wkhtmltopdf-armv5tel" 
chmod +x "/var/www/bin/wkhtmltopdf-armv5tel" 
touch /var/www/bin/wkhtmltoimage-armv5tel
chmod +x /var/www/bin/wkhtmltoimage-armv5tel
wget http://www.voipmonitor.org/downloads/arm/ioncube_loader.so -O /usr/lib/php5/20090626+lfs/ioncube_loader.so
echo "zend_extension = /usr/lib/php5/20090626+lfs/ioncube_loader.so" > /etc/php5/apache2/conf.d/ioncube.ini
/etc/init.d/apache2 restart